VDB

RHSA-2022%3A0737

RHSA-2022%3A0737 PUBLISHED CVSS 5.900000095367432 MEDIUM

Record from redhat · Published March 31, 2022

Some components in Apache Kafka use `Arrays.equals` to validate a password or key, which is vulnerable to timing attacks that make brute force attacks for such credentials more likely to be successful. Users should upgrade to 2.8.1 or higher, or 3.0.0 or higher where this vulnerability has been fixed. The affected versions include Apache Kafka 2.0.0, 2.0.1, 2.1.0, 2.1.1, 2.2.0, 2.2.1, 2.2.2, 2.3.0, 2.3.1, 2.4.0, 2.4.1, 2.5.0, 2.5.1, 2.6.0, 2.6.1, 2.6.2, 2.7.0, 2.7.1, and 2.8.0.

Risk scores

CVSS 3.1
5.900000095367432
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

Affected products

VendorProductVersions
Red HatVert.x 4.2.5

Timeline

  • Mar 31, 2022 CVE Published
  • May 1, 2026 Distribution Patch (2 in total, the first dated here)
  • May 1, 2026 Security Advisory (2 in total, the first dated here)
  • May 14, 2026 CVE Updated

Query this with the API

The same record, from the CLI:

vulnetix vdb vuln RHSA-2022%3A0737
vulnetix vdb fixes RHSA-2022%3A0737

Or with curl, using the org id and key from your account page:

curl -s -H "Authorization: ApiKey ${VULNETIX_ORG_ID}:${VULNETIX_API_KEY}" \
  "https://api.vdb.vulnetix.com/v2/vuln/RHSA-2022%253A0737/fixes/registry"

The Community plan is free and allows 50 queries a day. Get a free API key · API quickstart

Look up in the Resolve Platform →
$ Lookup Community · 50/day Open Lookup ›