PYSEC-2024-69
Record from OSV · Published August 7, 2024
django is fixed in 5.0.8 and 4.2.15 (PyPI)
An issue was discovered in Django 5.0 before 5.0.8 and 4.2 before 4.2.15. The urlize and urlizetrunc template filters, and the AdminURLFieldWidget widget, are subject to a potential denial-of-service attack via certain inputs with a very large number of Unicode characters.
Fixed versions
Upgrade to a fixed version or later. Language registries are listed first, then Linux distributions, then vendor products.
| Package | Ecosystem | Fixed in |
|---|---|---|
| django | PyPI | 5.0.8, 4.2.15 |
Risk scores
Affected products
| Vendor | Product | Versions |
|---|---|---|
| PyPI | django | 4.2, 4.2, 4.2.1 |
Timeline
- Aug 7, 2024 CVE Published
- Aug 8, 2024 CVE Updated
Query this with the API
The same record, from the CLI:
vulnetix vdb vuln PYSEC-2024-69
vulnetix vdb fixes PYSEC-2024-69
Or with curl, using the org id and key from your account page:
curl -s -H "Authorization: ApiKey ${VULNETIX_ORG_ID}:${VULNETIX_API_KEY}" \
"https://api.vdb.vulnetix.com/v2/vuln/PYSEC-2024-69/fixes/registry"
The Community plan is free and allows 50 queries a day. Get a free API key · API quickstart