PYSEC-2024-57
Record from OSV · Published July 10, 2024
django is fixed in 5.0.7 and 4.2.14 (PyPI)
An issue was discovered in Django 5.0 before 5.0.7 and 4.2 before 4.2.14. The django.contrib.auth.backends.ModelBackend.authenticate() method allows remote attackers to enumerate users via a timing attack involving login requests for users with an unusable password.
Fixed versions
Upgrade to a fixed version or later. Language registries are listed first, then Linux distributions, then vendor products.
| Package | Ecosystem | Fixed in |
|---|---|---|
| django | PyPI | 5.0.7, 4.2.14 |
Affected products
| Vendor | Product | Versions |
|---|---|---|
| PyPI | django | 4.2.8, 4.2, 4.2.1 |
Timeline
- Jul 10, 2024 CVE Published
- Mar 10, 2025 CVE Updated
Query this with the API
The same record, from the CLI:
vulnetix vdb vuln PYSEC-2024-57
vulnetix vdb fixes PYSEC-2024-57
Or with curl, using the org id and key from your account page:
curl -s -H "Authorization: ApiKey ${VULNETIX_ORG_ID}:${VULNETIX_API_KEY}" \
"https://api.vdb.vulnetix.com/v2/vuln/PYSEC-2024-57/fixes/registry"
The Community plan is free and allows 50 queries a day. Get a free API key · API quickstart