PYSEC-2024-156
Record from OSV · Published December 6, 2024
django is fixed in 5.1.4, 5.0.10 and 4.2.17 (PyPI)
An issue was discovered in Django 5.1 before 5.1.4, 5.0 before 5.0.10, and 4.2 before 4.2.17. The strip_tags() method and striptags template filter are subject to a potential denial-of-service attack via certain inputs containing large sequences of nested incomplete HTML entities.
Fixed versions
Upgrade to a fixed version or later. Language registries are listed first, then Linux distributions, then vendor products.
| Package | Ecosystem | Fixed in |
|---|---|---|
| django | PyPI | 5.1.4, 5.0.10, 4.2.17 |
Risk scores
Affected products
| Vendor | Product | Versions |
|---|---|---|
| PyPI | django | 4.2.13, 5.1, 4.2.11 |
Timeline
- Dec 6, 2024 CVE Published
- Mar 10, 2025 CVE Updated
Query this with the API
The same record, from the CLI:
vulnetix vdb vuln PYSEC-2024-156
vulnetix vdb fixes PYSEC-2024-156
Or with curl, using the org id and key from your account page:
curl -s -H "Authorization: ApiKey ${VULNETIX_ORG_ID}:${VULNETIX_API_KEY}" \
"https://api.vdb.vulnetix.com/v2/vuln/PYSEC-2024-156/fixes/registry"
The Community plan is free and allows 50 queries a day. Get a free API key · API quickstart