PYSEC-2021-142
Record from OSV · Published February 9, 2021
pyyaml is fixed in 5.4 (PyPI)
A vulnerability was discovered in the PyYAML library in versions before 5.4, where it is susceptible to arbitrary code execution when it processes untrusted YAML files through the full_load method or with the FullLoader loader. Applications that use the library to process untrusted input may be vulnerable to this flaw. This flaw allows an attacker to execute arbitrary code on the system by abusing the python/object/new constructor. This flaw is due to an incomplete fix for CVE-2020-1747.
Fixed versions
Upgrade to a fixed version or later. Language registries are listed first, then Linux distributions, then vendor products.
| Package | Ecosystem | Fixed in |
|---|---|---|
| pyyaml | PyPI | 5.4 |
Risk scores
Affected products
| Vendor | Product | Versions |
|---|---|---|
| PyPI | pyyaml | 4.2b1, 0, 3.01 |
Timeline
- Feb 9, 2021 CVE Published
- Nov 8, 2023 CVE Updated
Query this with the API
The same record, from the CLI:
vulnetix vdb vuln PYSEC-2021-142
vulnetix vdb fixes PYSEC-2021-142
Or with curl, using the org id and key from your account page:
curl -s -H "Authorization: ApiKey ${VULNETIX_ORG_ID}:${VULNETIX_API_KEY}" \
"https://api.vdb.vulnetix.com/v2/vuln/PYSEC-2021-142/fixes/registry"
The Community plan is free and allows 50 queries a day. Get a free API key · API quickstart