VDB
PYSEC-2019-146
PYSEC-2019-146
PUBLISHED
Record from OSV · Published November 26, 2019
ansible is fixed in 2.8.6, 2.7.14 and 2.6.20 (PyPI)
ansible before versions 2.8.6, 2.7.14, 2.6.20 is vulnerable to a None
Fixed versions
Upgrade to a fixed version or later. Language registries are listed first, then Linux distributions, then vendor products.
| Package | Ecosystem | Fixed in |
|---|---|---|
| ansible | PyPI | 2.8.6, 2.7.14, 2.6.20 |
Affected products
| Vendor | Product | Versions |
|---|---|---|
| PyPI | ansible | 2.8.0, 2.6.0, 2.7.0 |
Timeline
- Nov 26, 2019 CVE Published
- Nov 8, 2023 CVE Updated
- May 18, 2026 Distribution Patch
- May 18, 2026 Security Advisory
Query this with the API
The same record, from the CLI:
vulnetix vdb vuln PYSEC-2019-146
vulnetix vdb fixes PYSEC-2019-146
Or with curl, using the org id and key from your account page:
curl -s -H "Authorization: ApiKey ${VULNETIX_ORG_ID}:${VULNETIX_API_KEY}" \
"https://api.vdb.vulnetix.com/v2/vuln/PYSEC-2019-146/fixes/registry"
The Community plan is free and allows 50 queries a day. Get a free API key · API quickstart