VDB
PYSEC-2018-38
PYSEC-2018-38
PUBLISHED
CVSS 9.300000190734863 CRITICAL
Record from OSV · Published July 31, 2018
ansible is fixed in 2.2.0.0 (PyPI)
Ansible before version 2.2.0 fails to properly sanitize fact variables sent from the Ansible controller. An attacker with the ability to create special variables on the controller could execute arbitrary commands on Ansible clients as the user Ansible runs as.
Fixed versions
Upgrade to a fixed version or later. Language registries are listed first, then Linux distributions, then vendor products.
| Package | Ecosystem | Fixed in |
|---|---|---|
| ansible | PyPI | 2.2.0.0 |
Risk scores
CVSS 4.0
9.300000190734863
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
Affected products
| Vendor | Product | Versions |
|---|---|---|
| PyPI | ansible | 0, 1.1, 1.2 |
Timeline
- Jul 31, 2018 CVE Published
- Nov 8, 2023 CVE Updated
- May 18, 2026 Distribution Patch
- May 18, 2026 Security Advisory
Query this with the API
The same record, from the CLI:
vulnetix vdb vuln PYSEC-2018-38
vulnetix vdb fixes PYSEC-2018-38
Or with curl, using the org id and key from your account page:
curl -s -H "Authorization: ApiKey ${VULNETIX_ORG_ID}:${VULNETIX_API_KEY}" \
"https://api.vdb.vulnetix.com/v2/vuln/PYSEC-2018-38/fixes/registry"
The Community plan is free and allows 50 queries a day. Get a free API key · API quickstart