VDB

PYSEC-2015-20

PYSEC-2015-20 PUBLISHED CVSS 8.699999809265137 HIGH

Record from OSV · Published July 14, 2015

django is fixed in 1.8.3, 1.7.9 and 1.4.21 (PyPI)

The session backends in Django before 1.4.21, 1.5.x through 1.6.x, 1.7.x before 1.7.9, and 1.8.x before 1.8.3 allows remote attackers to cause a denial of service (session store consumption) via multiple requests with unique session keys.

Fixed versions

Upgrade to a fixed version or later. Language registries are listed first, then Linux distributions, then vendor products.

PackageEcosystemFixed in
djangoPyPI1.8.3, 1.7.9, 1.4.21

Risk scores

CVSS 4.0
8.699999809265137
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Affected products

VendorProductVersions
PyPIdjango1.0.1, 0, 1.5

Timeline

  • Jul 14, 2015 CVE Published
  • Nov 8, 2023 CVE Updated
  • May 1, 2026 Distribution Patch (2 in total, the first dated here)
  • May 1, 2026 Security Advisory (2 in total, the first dated here)

Query this with the API

The same record, from the CLI:

vulnetix vdb vuln PYSEC-2015-20
vulnetix vdb fixes PYSEC-2015-20

Or with curl, using the org id and key from your account page:

curl -s -H "Authorization: ApiKey ${VULNETIX_ORG_ID}:${VULNETIX_API_KEY}" \
  "https://api.vdb.vulnetix.com/v2/vuln/PYSEC-2015-20/fixes/registry"

The Community plan is free and allows 50 queries a day. Get a free API key · API quickstart

Look up in the Resolve Platform →
$ Lookup Community · 50/day Open Lookup ›