VDB
GHSA-v3p8-j597-3xg8
GHSA-v3p8-j597-3xg8
PUBLISHED
CVSS 7.5 HIGH
Record from GitHub Advisory Database · Published July 17, 2022
hive is fixed in 3.1.3 (Maven Central)
Apache Hive before 3.1.3 `CREATE` and `DROP` function operations do not check for necessary authorization.
Fixed versions
Upgrade to a fixed version or later. Language registries are listed first, then Linux distributions, then vendor products.
| Package | Ecosystem | Fixed in |
|---|---|---|
| org.apache.hive:hive | Maven Central | 3.1.3 |
Risk scores
CVSS 3.1
7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Affected products
| Vendor | Product | Versions |
|---|---|---|
| Maven | org.apache.hive:hive | 0 |
Timeline
- Jul 17, 2022 CVE Published
- Apr 9, 2026 Security Advisory
Query this with the API
The same record, from the CLI:
vulnetix vdb vuln GHSA-v3p8-j597-3xg8
vulnetix vdb fixes GHSA-v3p8-j597-3xg8
Or with curl, using the org id and key from your account page:
curl -s -H "Authorization: ApiKey ${VULNETIX_ORG_ID}:${VULNETIX_API_KEY}" \
"https://api.vdb.vulnetix.com/v2/vuln/GHSA-v3p8-j597-3xg8/fixes/registry"
The Community plan is free and allows 50 queries a day. Get a free API key · API quickstart