VDB
GHSA-hrh5-4ffc-228q
GHSA-hrh5-4ffc-228q
PUBLISHED
CVSS 8.100000381469727 HIGH
Record from GitHub Advisory Database · Published July 1, 2024
Encoding problem in mod_proxy in Apache HTTP Server 2.4.59 and earlier allows request URLs with incorrect encoding to be sent to backend services, potentially bypassing authentication via crafted requests. Users are recommended to upgrade to version 2.4.60, which fixes this issue.
Risk scores
CVSS 3.1
8.100000381469727
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H
Timeline
- Jul 1, 2024 CVE Published
- May 1, 2026 Security Advisory
Query this with the API
The same record, from the CLI:
vulnetix vdb vuln GHSA-hrh5-4ffc-228q
vulnetix vdb fixes GHSA-hrh5-4ffc-228q
Or with curl, using the org id and key from your account page:
curl -s -H "Authorization: ApiKey ${VULNETIX_ORG_ID}:${VULNETIX_API_KEY}" \
"https://api.vdb.vulnetix.com/v2/vuln/GHSA-hrh5-4ffc-228q/fixes/registry"
The Community plan is free and allows 50 queries a day. Get a free API key · API quickstart