VDB

GHSA-98wm-3w3q-mw94

GHSA-98wm-3w3q-mw94 PUBLISHED CVSS 6.5 MEDIUM

snakeYAML before 1.31 vulnerable to Denial of Service due to Out-of-bounds Write

Record from GitHub Advisory Database · Published September 6, 2022

snakeyaml is fixed in 1.31 (Maven Central)

snakeYAML before 1.31 vulnerable to Denial of Service due to Out-of-bounds Write

Fixed versions

Upgrade to a fixed version or later. Language registries are listed first, then Linux distributions, then vendor products.

PackageEcosystemFixed in
org.yaml:snakeyamlMaven Central1.31
management-api-for-apache-cassandra-4.1Wolfi0.1.109-r0
management-api-for-apache-cassandra-5.0Wolfi0.1.89-r0
request-1277Chainguard0.1.89-r0
management-api-for-apache-cassandra-4.0Chainguard0.1.89-r0
management-api-for-apache-cassandra-5.0Chainguard0.1.89-r0
management-api-for-apache-cassandra-4.1Chainguard0.1.109-r0

Risk scores

CVSS 3.1
6.5
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Affected products

VendorProductVersions
wolficassandra-5.0*
wolfimanagement-api-for-apache-cassandra-4.10
wolfimanagement-api-for-apache-cassandra-5.00
chainguardrequest-12770
Mavenorg.yaml:snakeyaml0
chainguardcassandra-fips-5.0*
chainguardmanagement-api-for-apache-cassandra-4.00
chainguardmanagement-api-for-apache-cassandra-5.00
chainguardmanagement-api-for-apache-cassandra-4.10
chainguardcassandra-5.0*

Timeline

  • Sep 6, 2022 CVE Published
  • Apr 9, 2026 Security Advisory

Query this with the API

The same record, from the CLI:

vulnetix vdb vuln GHSA-98wm-3w3q-mw94
vulnetix vdb fixes GHSA-98wm-3w3q-mw94

Or with curl, using the org id and key from your account page:

curl -s -H "Authorization: ApiKey ${VULNETIX_ORG_ID}:${VULNETIX_API_KEY}" \
  "https://api.vdb.vulnetix.com/v2/vuln/GHSA-98wm-3w3q-mw94/fixes/registry"

The Community plan is free and allows 50 queries a day. Get a free API key · API quickstart

Look up in the Resolve Platform →
$ Lookup Community · 50/day Open Lookup ›