DEBIAN-CVE-2026-34483
Record from OSV · Published April 9, 2026
Improper Encoding or Escaping of Output vulnerability in the JsonAccessLogValve component of Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.20, from 10.1.0-M1 through 10.1.53, from 9.0.40 through 9.0.116. Users are recommended to upgrade to version 11.0.21, 10.1.54 or 9.0.117 , which fix the issue.
Fixed versions
Upgrade to a fixed version or later. Language registries are listed first, then Linux distributions, then vendor products.
| Package | Ecosystem | Fixed in |
|---|---|---|
| tomcat10 | Debian:14 | 10.1.54-1 |
| tomcat9 | Debian:14 | 9.0.70-2 |
| tomcat10 | Debian:12 | 10.1.55-1~deb12u1 |
| tomcat11 | Debian:14 | 11.0.21-1 |
| tomcat9 | Debian:13 | 9.0.70-2 |
| tomcat9 | Debian:12 | 9.0.70-2 |
| tomcat10 | Debian:13 | 10.1.55-1~deb13u1 |
| tomcat11 | Debian:13 | 11.0.22-1~deb13u1 |
Risk scores
Affected products
| Vendor | Product | Versions |
|---|---|---|
| Debian:14 | tomcat10 | 0, 10.1.52-2, 10.1.52-1~deb13u1 |
| Debian:14 | tomcat9 | 0 |
| Debian:12 | tomcat10 | 0, 10.1.25-2, 10.1.30-1 |
| Debian:14 | tomcat11 | 0, 11.0.11-1, 11.0.15-1~deb13u1 |
| Debian:13 | tomcat9 | 0 |
| Debian:12 | tomcat9 | 0 |
| Debian:13 | tomcat10 | 10.1.54-1, 10.1.55-1~deb12u1, 0 |
| Debian:13 | tomcat11 | 11.0.21-1, 11.0.18-1, 11.0.15-1~deb13u1 |
Timeline
- Apr 9, 2026 CVE Published
- Oct 27, 2026 CVE Updated
Query this with the API
The same record, from the CLI:
vulnetix vdb vuln DEBIAN-CVE-2026-34483
vulnetix vdb fixes DEBIAN-CVE-2026-34483
Or with curl, using the org id and key from your account page:
curl -s -H "Authorization: ApiKey ${VULNETIX_ORG_ID}:${VULNETIX_API_KEY}" \
"https://api.vdb.vulnetix.com/v2/vuln/DEBIAN-CVE-2026-34483/fixes/registry"
The Community plan is free and allows 50 queries a day. Get a free API key · API quickstart