DEBIAN-CVE-2025-66614
Record from OSV · Published February 17, 2026
Improper Input Validation vulnerability. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.14, from 10.1.0-M1 through 10.1.49, from 9.0.0-M1 through 9.0.112. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 through 8.5.100. Older EOL versions are not affected. Tomcat did not validate that the host name provided via the SNI extension was the same as the host name provided in the HTTP host header field. If Tomcat was configured with more than one virtual host and the TLS configuration for one of those hosts did not require client certificate authentication but another one did, it was possible for a client to bypass the client certificate authentication by sending different host names in the SNI extension and the HTTP host header field. The vulnerability only applies if client certificate authentication is only enforced at the Connector. It does not apply if client certificate authentication is enforced at the web application. Users are recommended to upgrade to version 11.0.15 or later, 10.1.50 or later or 9.0.113 or later, which fix the issue.
Fixed versions
Upgrade to a fixed version or later. Language registries are listed first, then Linux distributions, then vendor products.
| Package | Ecosystem | Fixed in |
|---|---|---|
| tomcat9 | Debian:12 | 9.0.70-2 |
| tomcat10 | Debian:12 | 10.1.52-1~deb12u1 |
| tomcat11 | Debian:14 | 11.0.15-1 |
| tomcat9 | Debian:13 | 9.0.70-2 |
| tomcat9 | Debian:14 | 9.0.70-2 |
| tomcat10 | Debian:14 | 10.1.52-1 |
| tomcat10 | Debian:13 | 10.1.52-1~deb13u1 |
| tomcat11 | Debian:13 | 11.0.15-1~deb13u1 |
Risk scores
Affected products
| Vendor | Product | Versions |
|---|---|---|
| Debian:12 | tomcat9 | 0 |
| Debian:12 | tomcat10 | 10.1.40-1~bpo12+1, 10.1.46-1, 10.1.6-1 |
| Debian:14 | tomcat11 | 11.0.15-1~deb13u1, 0, 11.0.11-1 |
| Debian:13 | tomcat9 | 0 |
| Debian:14 | tomcat9 | 0 |
| Debian:14 | tomcat10 | 10.1.46-1, 0, 10.1.40-1 |
| Debian:13 | tomcat10 | 10.1.52-1~deb12u1, 0, 10.1.40-1 |
| Debian:13 | tomcat11 | 11.0.11-1, 11.0.6-1, 0 |
Timeline
- Feb 17, 2026 CVE Published
- Sep 1, 2026 CVE Updated
Query this with the API
The same record, from the CLI:
vulnetix vdb vuln DEBIAN-CVE-2025-66614
vulnetix vdb fixes DEBIAN-CVE-2025-66614
Or with curl, using the org id and key from your account page:
curl -s -H "Authorization: ApiKey ${VULNETIX_ORG_ID}:${VULNETIX_API_KEY}" \
"https://api.vdb.vulnetix.com/v2/vuln/DEBIAN-CVE-2025-66614/fixes/registry"
The Community plan is free and allows 50 queries a day. Get a free API key · API quickstart