DEBIAN-CVE-2025-66030
Record from OSV · Published November 26, 2025
Forge (also called `node-forge`) is a native implementation of Transport Layer Security in JavaScript. An Integer Overflow vulnerability in node-forge versions 1.3.1 and below enables remote, unauthenticated attackers to craft ASN.1 structures containing OIDs with oversized arcs. These arcs may be decoded as smaller, trusted OIDs due to 32-bit bitwise truncation, enabling the bypass of downstream OID-based security decisions. This issue has been patched in version 1.3.2.
Risk scores
Affected products
| Vendor | Product | Versions |
|---|---|---|
| Debian:11 | node-node-forge | 0, 0.10.0~dfsg-3, 0.10.0~dfsg-3+deb11u1 |
Timeline
- Nov 26, 2025 CVE Published
- Aug 27, 2026 CVE Updated
Query this with the API
The same record, from the CLI:
vulnetix vdb vuln DEBIAN-CVE-2025-66030
vulnetix vdb fixes DEBIAN-CVE-2025-66030
Or with curl, using the org id and key from your account page:
curl -s -H "Authorization: ApiKey ${VULNETIX_ORG_ID}:${VULNETIX_API_KEY}" \
"https://api.vdb.vulnetix.com/v2/vuln/DEBIAN-CVE-2025-66030/fixes/registry"
The Community plan is free and allows 50 queries a day. Get a free API key · API quickstart