VDB

DEBIAN-CVE-2025-49812

DEBIAN-CVE-2025-49812 PUBLISHED CVSS 7.400000095367432 HIGH

In some mod_ssl configurations on Apache HTTP Server versions through to 2.4.63, an HTTP desynchronisation attack allows a man-in-the-middle attacker to hijack an HTTP session via a TLS upgrade. Only configurations using "SSLEngine optional" to enable TLS upgrades are affected. Users are recommended to upgrade to version 2.4.64, which removes support for TLS upgrade.

Risk Scores

CVSS 3.1
7.400000095367432
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N

Affected Products

VendorProductVersions
Debian:14apache20
Debian:13apache20
Debian:12apache22.4.57-2, 2.4.57-3, 2.4.58-1

Timeline

  • Jul 10, 2025 CVE Published
  • Sep 1, 2026 CVE Updated
Open in Interactive Console →
$ Console Community · 50/day Open console ›