DEBIAN-CVE-2024-7055
Record from OSV · Published August 6, 2024
A vulnerability was found in FFmpeg up to 7.0.1. It has been classified as critical. This affects the function pnm_decode_frame in the library /libavcodec/pnmdec.c. The manipulation leads to heap-based buffer overflow. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 7.0.2 is able to address this issue. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-273651.
Fixed versions
Upgrade to a fixed version or later. Language registries are listed first, then Linux distributions, then vendor products.
| Package | Ecosystem | Fixed in |
|---|---|---|
| ffmpeg | Debian:14 | 7:7.0.2-1 |
| ffmpeg | Debian:13 | 7:7.0.2-1 |
| ffmpeg | Debian:12 | 7:5.1.6-0+deb12u1 |
Risk scores
Affected products
| Vendor | Product | Versions |
|---|---|---|
| Debian:14 | ffmpeg | 0 |
| Debian:13 | ffmpeg | 0 |
| Debian:12 | ffmpeg | 7:5.1.3-1, 7:5.1.4-0+deb12u1, 7:5.1.5-0+deb12u1 |
Timeline
- Aug 6, 2024 CVE Published
- Sep 15, 2026 CVE Updated
Query this with the API
The same record, from the CLI:
vulnetix vdb vuln DEBIAN-CVE-2024-7055
vulnetix vdb fixes DEBIAN-CVE-2024-7055
Or with curl, using the org id and key from your account page:
curl -s -H "Authorization: ApiKey ${VULNETIX_ORG_ID}:${VULNETIX_API_KEY}" \
"https://api.vdb.vulnetix.com/v2/vuln/DEBIAN-CVE-2024-7055/fixes/registry"
The Community plan is free and allows 50 queries a day. Get a free API key · API quickstart