DEBIAN-CVE-2024-52317
Record from OSV · Published November 18, 2024
Incorrect object re-cycling and re-use vulnerability in Apache Tomcat. Incorrect recycling of the request and response used by HTTP/2 requests could lead to request and/or response mix-up between users. This issue affects Apache Tomcat: from 11.0.0-M23 through 11.0.0-M26, from 10.1.27 through 10.1.30, from 9.0.92 through 9.0.95. Users are recommended to upgrade to version 11.0.0, 10.1.31 or 9.0.96, which fixes the issue.
Fixed versions
Upgrade to a fixed version or later. Language registries are listed first, then Linux distributions, then vendor products.
| Package | Ecosystem | Fixed in |
|---|---|---|
| tomcat10 | Debian:14 | 10.1.31-1 |
| tomcat10 | Debian:13 | 10.1.31-1 |
Risk scores
Affected products
| Vendor | Product | Versions |
|---|---|---|
| Debian:14 | tomcat10 | 0 |
| Debian:13 | tomcat10 | 0 |
Timeline
- Nov 18, 2024 CVE Published
- Sep 15, 2026 CVE Updated
Query this with the API
The same record, from the CLI:
vulnetix vdb vuln DEBIAN-CVE-2024-52317
vulnetix vdb fixes DEBIAN-CVE-2024-52317
Or with curl, using the org id and key from your account page:
curl -s -H "Authorization: ApiKey ${VULNETIX_ORG_ID}:${VULNETIX_API_KEY}" \
"https://api.vdb.vulnetix.com/v2/vuln/DEBIAN-CVE-2024-52317/fixes/registry"
The Community plan is free and allows 50 queries a day. Get a free API key · API quickstart