VDB

DEBIAN-CVE-2024-44082

DEBIAN-CVE-2024-44082 PUBLISHED CVSS 4.300000190734863 MEDIUM

In OpenStack Ironic before 26.0.1 and ironic-python-agent before 9.13.1, there is a vulnerability in image processing, in which a crafted image could be used by an authenticated user to exploit undesired behaviors in qemu-img, including possible unauthorized access to potentially sensitive data. The affected/fixed version details are: Ironic: <21.4.3, >=22.0.0 <23.0.2, >=23.1.0 <24.1.2, >=25.0.0 <26.0.1; Ironic-python-agent: <9.4.2, >=9.5.0 <9.7.1, >=9.8.0 <9.11.1, >=9.12.0 <9.13.1.

Risk Scores

CVSS 3.1
4.300000190734863
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Affected Products

VendorProductVersions
Debian:13ironic-python-agent0
Debian:13ironic0
Debian:14ironic-python-agent0
Debian:12ironic1:21.1.0-3+deb12u1, 1:21.4.0-1, 1:21.4.0-2
Debian:14ironic0

Timeline

  • Sep 6, 2024 CVE Published
  • Sep 15, 2026 CVE Updated
Open in Interactive Console →
$ Console Community · 50/day Open console ›