DEBIAN-CVE-2024-44082
Record from OSV · Published September 6, 2024
In OpenStack Ironic before 26.0.1 and ironic-python-agent before 9.13.1, there is a vulnerability in image processing, in which a crafted image could be used by an authenticated user to exploit undesired behaviors in qemu-img, including possible unauthorized access to potentially sensitive data. The affected/fixed version details are: Ironic: <21.4.3, >=22.0.0 <23.0.2, >=23.1.0 <24.1.2, >=25.0.0 <26.0.1; Ironic-python-agent: <9.4.2, >=9.5.0 <9.7.1, >=9.8.0 <9.11.1, >=9.12.0 <9.13.1.
Fixed versions
Upgrade to a fixed version or later. Language registries are listed first, then Linux distributions, then vendor products.
| Package | Ecosystem | Fixed in |
|---|---|---|
| ironic-python-agent | Debian:13 | 9.14.0-1 |
| ironic | Debian:13 | 1:26.1.0-1 |
| ironic-python-agent | Debian:14 | 9.14.0-1 |
| ironic | Debian:12 | 1:21.4.4-0+deb12u1 |
| ironic | Debian:14 | 1:26.1.0-1 |
Risk scores
Affected products
| Vendor | Product | Versions |
|---|---|---|
| Debian:13 | ironic-python-agent | 0 |
| Debian:13 | ironic | 0 |
| Debian:14 | ironic-python-agent | 0 |
| Debian:12 | ironic | 1:21.1.0-3+deb12u1, 1:21.4.0-1, 1:21.4.0-2 |
| Debian:14 | ironic | 0 |
Timeline
- Sep 6, 2024 CVE Published
- Sep 15, 2026 CVE Updated
Query this with the API
The same record, from the CLI:
vulnetix vdb vuln DEBIAN-CVE-2024-44082
vulnetix vdb fixes DEBIAN-CVE-2024-44082
Or with curl, using the org id and key from your account page:
curl -s -H "Authorization: ApiKey ${VULNETIX_ORG_ID}:${VULNETIX_API_KEY}" \
"https://api.vdb.vulnetix.com/v2/vuln/DEBIAN-CVE-2024-44082/fixes/registry"
The Community plan is free and allows 50 queries a day. Get a free API key · API quickstart