CVE-2026-109841
undici vulnerable to Subresource Integrity bypass via non-lowercase algorithm tokens
Reported by openjs · Published October 15, 2026
undici is fixed in 8.12.2 and 7.30.1 (npm)
undici is an HTTP client library for Node.js. In versions 7.15.0 through 7.30.0 and 8.0.0 through 8.12.1, its fetch() implementation verifies Subresource Integrity metadata by matching the algorithm token against a lowercase-only set, even though the SRI specification defines the token by its ASCII-lowercase form, so a valid but non-lowercase token such as an uppercase or mixed-case SHA256 is treated as unknown and skipped. When no recognized algorithm remains, undici treats the integrity list as empty and accepts the response, so a server returning a body that does not match the pinned digest passes the check. An attacker who controls only the response body can therefore deliver attacker-controlled bytes to an application that pinned a valid uppercase or mixed-case SRI token, with no integrity error, affecting response integrity only. The issue is fixed in undici 7.30.1 and 8.12.2, which normalize the algorithm token to ASCII lowercase before validation, and users should upgrade to one of those versions or later. As a workaround, use lowercase algorithm tokens such as sha256, sha384, or sha512 in integrity metadata.
Fixed versions
Upgrade to a fixed version or later. Language registries are listed first, then Linux distributions, then vendor products.
| Package | Ecosystem | Fixed in |
|---|---|---|
| undici | npm | 8.12.2, 7.30.1 |
| lerna | Wolfi | 10.1.1-r3 |
| pelias-api | Chainguard | 7.11.0-r3 |
| nodejs24-libs | Amazon Linux | 1:24.22.1-1.amzn2023.0.1 |
| node-gyp | Wolfi | 13.1.0-r1 |
| nodejs24-docs | Amazon Linux | 1:24.22.1-1.amzn2023.0.1 |
| nodejs24-devel | Amazon Linux | 1:24.22.1-1.amzn2023.0.1 |
| nodejs24-full-i18n | Amazon Linux | 1:24.22.1-1.amzn2023.0.1 |
| vitess-24 | Chainguard | 24.0.5-r5 |
| nodejs24-npm | Amazon Linux | 1:11.19.1-1.24.22.1.1.amzn2023.0.1 |
| vitess-24 | Wolfi | 24.0.5-r5 |
| prism | Wolfi | 5.16.0-r19 |
5 more packages have a fixed version. See every fix in Lookup.
Risk scores
Affected products
| Vendor | Product | Versions |
|---|---|---|
| undici | undici | 7.15.0, 7.30.1, 8.0.0 |
| undici | undici | 8.12.2, 8.0.0, 7.30.1 |
| wolfi | lerna | 0 |
| chainguard | pelias-api | 0 |
| amazon:2023 | nodejs24-libs | 0 |
| wolfi | node-gyp | 0 |
| amazon:2023 | nodejs24-docs | 0 |
| amazon:2023 | nodejs24-devel | 0 |
| amazon:2023 | nodejs24-full-i18n | 0 |
| chainguard | vitess-24 | 0 |
| amazon:2023 | nodejs24-npm | 0 |
| wolfi | vitess-24 | 0 |
| wolfi | prism | 0 |
| amazon:2023 | v8-13.6-devel | 0 |
| chainguard | prism | 0 |
| amazon:2023 | nodejs24 | 0 |
| npm | undici | 8.0.0, 7.15.0 |
Timeline
- Oct 15, 2026 Coalition ESS Score
- Oct 15, 2026 CVE Published
- Oct 16, 2026 EPSS Score (5 in total, the first dated here)
- Oct 16, 2026 CVE Updated
- Oct 31, 2026 Security Advisory
Query this with the API
The same record, from the CLI:
vulnetix vdb vuln CVE-2026-109841
vulnetix vdb fixes CVE-2026-109841
Or with curl, using the org id and key from your account page:
curl -s -H "Authorization: ApiKey ${VULNETIX_ORG_ID}:${VULNETIX_API_KEY}" \
"https://api.vdb.vulnetix.com/v2/vuln/CVE-2026-109841/fixes/registry"
The Community plan is free and allows 50 queries a day. Get a free API key · API quickstart
References
- https://nvd.nist.gov/vuln/detail/CVE-2026-109841 advisory
- https://github.com/advisories/GHSA-f72v-6w45-q472 advisory
- https://github.com/nodejs/undici/commit/18bc8a1e09d15bc45815154a289dcf6fd5254d00 patch
- https://github.com/nodejs/undici/commit/4f7ef6806e532ab9e29ccd6229b1b9d241e1b1f0 patch
- https://github.com/nodejs/undici/releases/tag/v7.30.1 url
- https://github.com/nodejs/undici/releases/tag/v8.12.2 url