VDB

CVE-2025-66040

CVE-2025-66040 PUBLISHED CVSS 3.6 LOW

Spotipy has a XSS vulnerability in OAuth callback server

Reported by github_m · Published November 26, 2025

Spotipy is a Python library for the Spotify Web API. Prior to version 2.25.2, there is a cross-site scripting (XSS) vulnerability in the OAuth callback server that allows for JavaScript injection through the unsanitized error parameter. Attackers can execute arbitrary JavaScript in the user's browser during OAuth authentication. This issue has been patched in version 2.25.2.

Risk scores

CVSS 3.1
3.6
CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N

Affected products

VendorProductVersions
spotipy-devspotipy< 2.25.2
PyPIspotipy0
spotipy-devspotipy0

Timeline

  • Nov 26, 2025 CVE Published
  • Nov 27, 2025 EPSS Score (30 in total, the first dated here)
  • Nov 27, 2025 Coalition ESS Score (5 in total, the first dated here)
  • Nov 27, 2025 PoC Published
  • Dec 7, 2025 Security Advisory
  • Jul 7, 2026 CVE Updated

Query this with the API

The same record, from the CLI:

vulnetix vdb vuln CVE-2025-66040
vulnetix vdb fixes CVE-2025-66040

Or with curl, using the org id and key from your account page:

curl -s -H "Authorization: ApiKey ${VULNETIX_ORG_ID}:${VULNETIX_API_KEY}" \
  "https://api.vdb.vulnetix.com/v2/vuln/CVE-2025-66040/fixes/registry"

The Community plan is free and allows 50 queries a day. Get a free API key · API quickstart

Look up in the Resolve Platform →
$ Lookup Community · 50/day Open Lookup ›