CVE-2025-29891
Apache Camel: Camel Message Header Injection through request parameters
Reported by apache · Published March 12, 2025
camel-support is fixed in 4.10.2, 4.8.5 and 3.22.4 (Maven Central)
Bypass/Injection vulnerability in Apache Camel. This issue affects Apache Camel: from 4.10.0 before 4.10.2, from 4.8.0 before 4.8.5, from 3.10.0 before 3.22.4. Users are recommended to upgrade to version 4.10.2 for 4.10.x LTS, 4.8.5 for 4.8.x LTS and 3.22.4 for 3.x releases. This vulnerability is present in Camel's default incoming header filter, that allows an attacker to include Camel specific headers that for some Camel components can alter the behaviours such as the camel-bean component, or the camel-exec component. If you have Camel applications that are directly connected to the internet via HTTP, then an attacker could include parameters in the HTTP requests that are sent to the Camel application that get translated into headers. The headers could be both provided as request parameters for an HTTP methods invocation or as part of the payload of the HTTP methods invocation. All the known Camel HTTP component such as camel-servlet, camel-jetty, camel-undertow, camel-platform-http, and camel-netty-http would be vulnerable out of the box. This CVE is related to the CVE-2025-27636: while they have the same root cause and are fixed with the same fix, CVE-2025-27636 was assumed to only be exploitable if an attacker could add malicious HTTP headers, while we have now determined that it is also exploitable via HTTP parameters. Like in CVE-2025-27636, exploitation is only possible if the Camel route uses particular vulnerable components.
Fixed versions
Upgrade to a fixed version or later. Language registries are listed first, then Linux distributions, then vendor products.
| Package | Ecosystem | Fixed in |
|---|---|---|
| org.apache.camel:camel-support | Maven Central | 4.10.2, 4.8.5, 3.22.4 |
| org.apache.camel:camel | Maven Central | 4.10.2, 4.8.5, 3.22.4 |
| camel | apache | 4.10.2, 4.8.5, 3.22.4 |
Risk scores
Affected products
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Camel | 4.10.0, 4.8.0, 3.10.0 |
| Maven | org.apache.camel:camel-support | 3.10.0, 4.9.0, 4.0.0-M1 |
| Apache Software Foundation | Apache Camel | 4.10.0, 4.8.0, 3.10.0 |
Timeline
- Mar 12, 2025 CVE Published
- Mar 12, 2025 PoC Published (24 in total, the first dated here)
- Mar 13, 2025 EPSS Score (30 in total, the first dated here)
- Mar 19, 2025 CVE Updated
- Mar 23, 2025 Coalition ESS Score (22 in total, the first dated here)
- Jul 3, 2025 VulnCheck KEV Exploitation
- Oct 23, 2025 VulnCheck XDB Entry
- Apr 2, 2026 Security Advisory
Query this with the API
The same record, from the CLI:
vulnetix vdb vuln CVE-2025-29891
vulnetix vdb fixes CVE-2025-29891
Or with curl, using the org id and key from your account page:
curl -s -H "Authorization: ApiKey ${VULNETIX_ORG_ID}:${VULNETIX_API_KEY}" \
"https://api.vdb.vulnetix.com/v2/vuln/CVE-2025-29891/fixes/registry"
The Community plan is free and allows 50 queries a day. Get a free API key · API quickstart
References
- related
- vendor-advisory
- https://nvd.nist.gov/vuln/detail/CVE-2025-29891 advisory
- https://github.com/advisories/GHSA-96v5-c2h5-56hm advisory
- https://github.com/apache/camel/commit/23a833eec6131a3cdce6e4b1b40b3ac2035b6adf patch
- https://github.com/apache/camel/commit/45a6b74f7f8af8fd58f197566938a9534392a624 patch
- https://github.com/apache/camel url
- https://issues.apache.org/jira/browse/CAMEL-21828 url
- https://github.com/akamai/CVE-2025-27636-Apache-Camel-PoC exploit