CVE-2025-2571
Google OAuth Authentication Bypass for Converted Bot Accounts
Reported by mattermost · Published May 30, 2025
github.com/mattermost/mattermost/server/v8 is fixed in 10.7.1, 10.6.3, 10.5.4 and 2 more (Go Modules)
Mattermost versions 10.7.x <= 10.7.0, 10.6.x <= 10.6.2, 10.5.x <= 10.5.3, 9.11.x <= 9.11.12 fail to clear Google OAuth credentials when converting user accounts to bot accounts, allowing attackers to gain unauthorized access to bot accounts via the Google OAuth signup flow.
Fixed versions
Upgrade to a fixed version or later. Language registries are listed first, then Linux distributions, then vendor products.
| Package | Ecosystem | Fixed in |
|---|---|---|
| github.com/mattermost/mattermost/server/v8 | Go Modules | 10.7.1, 10.6.3, 10.5.4, 9.11.13, 8.0.0-20250414095146-04676582cdd2 |
| github.com/mattermost/mattermost-server | Go Modules | 10.7.1+incompatible, 10.6.3+incompatible, 10.5.4+incompatible, 9.11.13+incompatible |
| mattermost_server | mattermost | 10.7.1, 10.6.3, 10.5.4, 9.11.13 |
Risk scores
Affected products
| Vendor | Product | Versions |
|---|---|---|
| Mattermost | Mattermost | 10.7.0, 10.6.0, 10.5.0 |
| Mattermost | Mattermost | 10.7.0, 10.6.0, 10.5.0 |
| github.com | mattermost/mattermost/server/v8 | 10.7.0-rc1, 10.0.0-rc1, 9.0.0-rc1 |
Timeline
- Apr 29, 2025 CVE Published
- May 31, 2025 EPSS Score (30 in total, the first dated here)
- Jun 10, 2025 Coalition ESS Score (9 in total, the first dated here)
- Aug 19, 2025 CVE Updated
- Mar 11, 2026 Security Advisory
Query this with the API
The same record, from the CLI:
vulnetix vdb vuln CVE-2025-2571
vulnetix vdb fixes CVE-2025-2571
Or with curl, using the org id and key from your account page:
curl -s -H "Authorization: ApiKey ${VULNETIX_ORG_ID}:${VULNETIX_API_KEY}" \
"https://api.vdb.vulnetix.com/v2/vuln/CVE-2025-2571/fixes/registry"
The Community plan is free and allows 50 queries a day. Get a free API key · API quickstart