CVE-2021-37682
Use of unitialized value in TensorFlow Lite
Reported by github_m · Published August 12, 2021
tensorflow-gpu is fixed in 2.5.1, 2.4.3 and 2.3.4 (PyPI)
TensorFlow is an end-to-end open source platform for machine learning. In affected versions all TFLite operations that use quantization can be made to use unitialized values. [For example](https://github.com/tensorflow/tensorflow/blob/460e000de3a83278fb00b61a16d161b1964f15f4/tensorflow/lite/kernels/depthwise_conv.cc#L198-L200). The issue stems from the fact that `quantization.params` is only valid if `quantization.type` is different that `kTfLiteNoQuantization`. However, these checks are missing in large parts of the code. We have patched the issue in GitHub commits 537bc7c723439b9194a358f64d871dd326c18887, 4a91f2069f7145aab6ba2d8cfe41be8a110c18a5 and 8933b8a21280696ab119b63263babdb54c298538. The fix will be included in TensorFlow 2.6.0. We will also cherrypick this commit on TensorFlow 2.5.1, TensorFlow 2.4.3, and TensorFlow 2.3.4, as these are also affected and still in supported range.
Fixed versions
Upgrade to a fixed version or later. Language registries are listed first, then Linux distributions, then vendor products.
| Package | Ecosystem | Fixed in |
|---|---|---|
| tensorflow-gpu | PyPI | 2.5.1, 2.4.3, 2.3.4 |
| tensorflow-lite | PyPI | 2.4.3, 2.3.4 |
| tensorflow-cpu | PyPI | 537bc7c723439b9194a358f64d871dd326c18887, 2.5.1, 2.4.3, 2.3.4 |
| tensorflow | PyPI | 2.5.1, 2.4.3, 2.3.4 |
Risk scores
Affected products
| Vendor | Product | Versions |
|---|---|---|
| tensorflow | tensorflow | >= 2.5.0, < 2.5.1, >= 2.4.0, < 2.4.3, < 2.3.4 |
| PyPI | tensorflow-lite | 0, 2.5.0, 2.4.0 |
| PyPI | tensorflow-gpu | 2.4.0, 2.5.0, 2.5.0 |
| tensorflow | tensorflow | 0, 2.4.0, 2.5.0 |
| arch | tensorflow | 0 |
| PyPI | tensorflow | 0, 2.5.0, 2.5.0 |
| PyPI | tensorflow-cpu | 0, 2.4.0, 2.5.0 |
Timeline
- Aug 12, 2021 CVE Published
- Aug 13, 2021 EPSS Score (30 in total, the first dated here)
- Nov 21, 2024 CVE Updated
- Mar 10, 2026 Security Advisory (2 in total, the first dated here)
- Jul 26, 2026 Coalition ESS Score
Query this with the API
The same record, from the CLI:
vulnetix vdb vuln CVE-2021-37682
vulnetix vdb fixes CVE-2021-37682
Or with curl, using the org id and key from your account page:
curl -s -H "Authorization: ApiKey ${VULNETIX_ORG_ID}:${VULNETIX_API_KEY}" \
"https://api.vdb.vulnetix.com/v2/vuln/CVE-2021-37682/fixes/registry"
The Community plan is free and allows 50 queries a day. Get a free API key · API quickstart
References
- x_refsource_CONFIRM
- x_refsource_MISC
- x_refsource_MISC
- x_refsource_MISC
- https://nvd.nist.gov/vuln/detail/CVE-2021-37682 advisory
- https://github.com/advisories/GHSA-4c4g-crqm-xrxw advisory
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-595.yaml advisory
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-793.yaml advisory
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-304.yaml advisory
- https://github.com/tensorflow/tensorflow url
- https://github.com/tensorflow/tensorflow/blob/460e000de3a83278fb00b61a16d161b1964f15f4/tensorflow/lite/kernels/depthwise_conv.cc#L198-L200 url