VDB

CVE-2021-37674

CVE-2021-37674 PUBLISHED CVSS 5.5 MEDIUM

Incomplete validation in `MaxPoolGrad` in TensorFlow

Reported by github_m · Published August 12, 2021

tensorflow-gpu is fixed in 2.5.1, 2.4.3 and 2.3.4 (PyPI)

TensorFlow is an end-to-end open source platform for machine learning. In affected versions an attacker can trigger a denial of service via a segmentation fault in `tf.raw_ops.MaxPoolGrad` caused by missing validation. The [implementation](https://github.com/tensorflow/tensorflow/blob/460e000de3a83278fb00b61a16d161b1964f15f4/tensorflow/core/kernels/maxpooling_op.cc) misses some validation for the `orig_input` and `orig_output` tensors. The fixes for CVE-2021-29579 were incomplete. We have patched the issue in GitHub commit 136b51f10903e044308cf77117c0ed9871350475. The fix will be included in TensorFlow 2.6.0. We will also cherrypick this commit on TensorFlow 2.5.1, TensorFlow 2.4.3, and TensorFlow 2.3.4, as these are also affected and still in supported range.

Fixed versions

Upgrade to a fixed version or later. Language registries are listed first, then Linux distributions, then vendor products.

PackageEcosystemFixed in
tensorflow-gpuPyPI2.5.1, 2.4.3, 2.3.4
tensorflowPyPI2.5.1, 2.4.3, 2.3.4
tensorflow-cpuPyPI2.5.1, 2.4.3, 2.3.4, 136b51f10903e044308cf77117c0ed9871350475
tensorflowArch Linux2.5.1-1
tensorflowBitnami2.5.1, 2.4.3, 2.3.4
tensorflowBitnami2.5.1, 2.4.3, 2.3.4
tensorflowgoogle2.4.3, 2.3.4

Risk scores

CVSS 3.1
5.5
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Affected products

VendorProductVersions
tensorflowtensorflow>= 2.5.0, < 2.5.1, >= 2.4.0, < 2.4.3, < 2.3.4
archtensorflow0
PyPItensorflow-gpu2.5.0, 0, 2.4.0
PyPItensorflow-cpu0, 2.4.0, 2.5.0
tensorflowtensorflow2.4.0, 0, 2.5.0
PyPItensorflow0, 2.5.0, 2.5.0

Timeline

  • Aug 12, 2021 CVE Published
  • Aug 13, 2021 EPSS Score (30 in total, the first dated here)
  • Mar 9, 2026 Security Advisory (2 in total, the first dated here)
  • Jul 26, 2026 Coalition ESS Score
  • Sep 20, 2026 CVE Updated

Query this with the API

The same record, from the CLI:

vulnetix vdb vuln CVE-2021-37674
vulnetix vdb fixes CVE-2021-37674

Or with curl, using the org id and key from your account page:

curl -s -H "Authorization: ApiKey ${VULNETIX_ORG_ID}:${VULNETIX_API_KEY}" \
  "https://api.vdb.vulnetix.com/v2/vuln/CVE-2021-37674/fixes/registry"

The Community plan is free and allows 50 queries a day. Get a free API key · API quickstart

Look up in the Resolve Platform →
$ Lookup Community · 50/day Open Lookup ›