VDB

CVE-2020-29651

CVE-2020-29651 PUBLISHED CVSS 7.5 HIGH

py vulnerable to Regular Expression Denial of Service

Reported by mitre · Published December 9, 2020

py is fixed in 1.10.0 (PyPI)

A denial of service via regular expression in the py.path.svnwc component of py (aka python-py) through 1.9.0 could be used by attackers to cause a compute-time denial of service attack by supplying malicious input to the blame functionality.

Fixed versions

Upgrade to a fixed version or later. Language registries are listed first, then Linux distributions, then vendor products.

PackageEcosystemFixed in
pyPyPI1.10.0
python-pyArch Linux1.10.0-1
pypytest1.9.0
python-pyUbuntu:20.04:LTS1.8.1-1ubuntu0.1
python-pyUbuntu:18.04:LTS1.5.2-1ubuntu0.1

Risk scores

CVSS 3.1
7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Affected products

VendorProductVersions
n/an/an/a
PyPIpy0
archpython-py0
n/an/a*

Timeline

  • Dec 9, 2020 CVE Published
  • Apr 14, 2021 EPSS Score (30 in total, the first dated here)
  • Nov 3, 2025 CVE Updated
  • Mar 6, 2026 Distribution Patch
  • Mar 6, 2026 Security Advisory (4 in total, the first dated here)
  • Aug 31, 2026 Coalition ESS Score

Query this with the API

The same record, from the CLI:

vulnetix vdb vuln CVE-2020-29651
vulnetix vdb fixes CVE-2020-29651

Or with curl, using the org id and key from your account page:

curl -s -H "Authorization: ApiKey ${VULNETIX_ORG_ID}:${VULNETIX_API_KEY}" \
  "https://api.vdb.vulnetix.com/v2/vuln/CVE-2020-29651/fixes/registry"

The Community plan is free and allows 50 queries a day. Get a free API key · API quickstart

Look up in the Resolve Platform →
$ Lookup Community · 50/day Open Lookup ›