VDB
CVE-2020-26892
CVE-2020-26892
PUBLISHED
CVSS 9.800000190734863 CRITICAL
Incorrect handling of credential expiry by /nats-io/nats-server
Record from NVD · Published November 6, 2020
github.com/nats-io/jwt is fixed in 1.1.0 (Go Modules)
The JWT library in NATS nats-server before 2.1.9 has Incorrect Access Control because of how expired credentials are handled.
EPSS 2.33% · 83.5th percentile
Fixed versions
Upgrade to a fixed version or later. Language registries are listed first, then Linux distributions, then vendor products.
| Package | Ecosystem | Fixed in |
|---|---|---|
| github.com/nats-io/jwt | Go Modules | 1.1.0 |
| github.com/nats-io/nats-server/v2 | Go Modules | 2.1.9 |
| nats-server | linuxfoundation | 2.1.9 |
Risk scores
CVSS 3.1
9.800000190734863
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS Score
2.33%
83.5th percentile
Affected products
| Vendor | Product | Versions |
|---|---|---|
| fedoraproject | fedora | 33 |
| linuxfoundation | nats-server | 0 |
Timeline
- Nov 6, 2020 CVE Published
- Apr 14, 2021 EPSS Score (30 in total, the first dated here)
- Mar 10, 2026 Security Advisory
- Jun 17, 2026 CVE Updated
- Sep 1, 2026 Coalition ESS Score
Query this with the API
The same record, from the CLI:
vulnetix vdb vuln CVE-2020-26892
vulnetix vdb fixes CVE-2020-26892
Or with curl, using the org id and key from your account page:
curl -s -H "Authorization: ApiKey ${VULNETIX_ORG_ID}:${VULNETIX_API_KEY}" \
"https://api.vdb.vulnetix.com/v2/vuln/CVE-2020-26892/fixes/registry"
The Community plan is free and allows 50 queries a day. Get a free API key · API quickstart