CVE-2020-11029
Cross-site scripting in stats method (object cache) in WordPress
Reported by github_m · Published April 30, 2020
In affected versions of WordPress, a vulnerability in the stats() method of class-wp-object-cache.php can be exploited to execute cross-site scripting (XSS) attacks. This has been patched in version 5.4.1, along with all the previously affected versions via a minor release (5.3.3, 5.2.6, 5.1.5, 5.0.9, 4.9.14, 4.8.13, 4.7.17, 4.6.18, 4.5.21, 4.4.22, 4.3.23, 4.2.27, 4.1.30, 4.0.30, 3.9.31, 3.8.33, 3.7.33).
Fixed versions
Upgrade to a fixed version or later. Language registries are listed first, then Linux distributions, then vendor products.
| Package | Ecosystem | Fixed in |
|---|---|---|
| wordpress-multisite | Bitnami | 5.4.1, 5.3.3, 5.2.6, 5.1.5, 5.0.9, 4.9.14, 4.8.13, 4.7.17, 4.6.18, 4.5.21, 4.4.22, 4.3.23, 4.2.27, 4.1.30, 4.0.30, 3.9.31, 3.8.33, 3.7.33 |
Risk scores
Affected products
| Vendor | Product | Versions |
|---|---|---|
| WordPress | WordPress | >= 5.4.0, < 5.4.1, >= 5.3.0, < 5.3.3, >= 5.2.0, < 5.2.6 |
| WordPress | WordPress | 5.4.0, 5.3.0, 5.2.0 |
Timeline
- Apr 30, 2020 CVE Published
- Apr 14, 2021 EPSS Score (30 in total, the first dated here)
- Aug 4, 2024 CVE Updated
- Aug 10, 2026 Distribution Patch
- Aug 10, 2026 Security Advisory
- Sep 6, 2026 Coalition ESS Score
Query this with the API
The same record, from the CLI:
vulnetix vdb vuln CVE-2020-11029
vulnetix vdb fixes CVE-2020-11029
Or with curl, using the org id and key from your account page:
curl -s -H "Authorization: ApiKey ${VULNETIX_ORG_ID}:${VULNETIX_API_KEY}" \
"https://api.vdb.vulnetix.com/v2/vuln/CVE-2020-11029/fixes/registry"
The Community plan is free and allows 50 queries a day. Get a free API key · API quickstart
References
- x_refsource_MISC
- x_refsource_CONFIRM
- DSA-4677 vendor-advisoryx_refsource_DEBIAN
- [debian-lts-announce] 20200511 [SECURITY] [DLA 2208-1] wordpress security update mailing-listx_refsource_MLIST