ALPINE-CVE-2025-49812
Record from OSV · Published July 10, 2025
In some mod_ssl configurations on Apache HTTP Server versions through to 2.4.63, an HTTP desynchronisation attack allows a man-in-the-middle attacker to hijack an HTTP session via a TLS upgrade. Only configurations using "SSLEngine optional" to enable TLS upgrades are affected. Users are recommended to upgrade to version 2.4.64, which removes support for TLS upgrade.
Fixed versions
Upgrade to a fixed version or later. Language registries are listed first, then Linux distributions, then vendor products.
| Package | Ecosystem | Fixed in |
|---|---|---|
| apache2 | Alpine:v3.24 | 2.4.64-r0 |
| apache2 | Alpine:v3.19 | 2.4.64-r0 |
| apache2 | Alpine:v3.22 | 2.4.64-r0 |
| apache2 | Alpine:v3.20 | 2.4.64-r0 |
| apache2 | Alpine:v3.23 | 2.4.64-r0 |
| apache2 | Alpine:v3.21 | 2.4.64-r0 |
Risk scores
Affected products
| Vendor | Product | Versions |
|---|---|---|
| Alpine:v3.24 | apache2 | 0 |
| Alpine:v3.19 | apache2 | 2.2.17-r3, 2.2.17-r4, 2.2.17-r5 |
| Alpine:v3.22 | apache2 | 2.2.17-r0, 2.2.16-r3, 2.2.16-r2 |
| Alpine:v3.20 | apache2 | 0, 2.2.16-r0, 2.2.16-r1 |
| Alpine:v3.23 | apache2 | 2.4.57-r0, 2.4.57-r1, 2.4.25-r1 |
| Alpine:v3.21 | apache2 | 2.2.16-r0, 2.2.16-r2, 2.2.16-r3 |
Timeline
- Jul 10, 2025 CVE Published
- Jun 15, 2026 CVE Updated
- Aug 8, 2026 Distribution Patch
Query this with the API
The same record, from the CLI:
vulnetix vdb vuln ALPINE-CVE-2025-49812
vulnetix vdb fixes ALPINE-CVE-2025-49812
Or with curl, using the org id and key from your account page:
curl -s -H "Authorization: ApiKey ${VULNETIX_ORG_ID}:${VULNETIX_API_KEY}" \
"https://api.vdb.vulnetix.com/v2/vuln/ALPINE-CVE-2025-49812/fixes/registry"
The Community plan is free and allows 50 queries a day. Get a free API key · API quickstart